SEARCH
NEW RPMS
DIRECTORIES
ABOUT
FAQ
VARIOUS
BLOG
DONATE


YUM REPOSITORY

 
 

python3-strictyaml rpm build for : Fedora Other. For other distributions click python3-strictyaml.

Name : python3-strictyaml
Version : 1.4.0 Vendor : Fedora Project
Release : 1.20210329gitae2131a.fc34 Date : 2021-03-29 16:48:14
Group : Unspecified Source RPM : python-strictyaml-1.4.0-1.20210329gitae2131a.fc34.src.rpm
Size : 0.22 MB
Packager : Fedora Project
Summary : Parses and validates a restricted subset of YAML
Description :
StrictYAML is a type-safe YAML parser that parses and validates a restricted
subset of the YAML specification.

Priorities:

• Beautiful API
• Refusing to parse the ugly, hard to read and insecure features of YAML like
the Norway problem.
• Strict validation of markup and straightforward type casting.
• Clear, readable exceptions with code snippets and line numbers.
• Acting as a near-drop in replacement for pyyaml, ruamel.yaml or poyo.
• Ability to read in YAML, make changes and write it out again with comments
preserved.
• Not speed, currently.

RPM found in directory: /mirror/download.fedora.redhat.com/pub/fedora/linux/development/34/Everything/aarch64/os/Packages/p

Content of RPM  Changelog  Provides Requires

Download
ftp.pbone.net  python3-strictyaml-1.4.0-1.20210329gitae2131a.fc34.noarch.rpm
ftp.pbone.net  python3-strictyaml-1.4.0-1.20210329gitae2131a.fc34.noarch.rpm
ftp.pbone.net  python3-strictyaml-1.4.0-1.20210329gitae2131a.fc34.noarch.rpm
ftp.pbone.net  python3-strictyaml-1.4.0-1.20210329gitae2131a.fc34.noarch.rpm
ftp.pbone.net  python3-strictyaml-1.4.0-1.20210329gitae2131a.fc34.noarch.rpm
ftp.pbone.net  python3-strictyaml-1.4.0-1.20210329gitae2131a.fc34.noarch.rpm
     

Provides :
python-strictyaml
python3-strictyaml
python3.9-strictyaml
python3.9dist(strictyaml)
python3dist(strictyaml)

Requires :
python(abi) = 3.9
python3.9dist(python-dateutil) >= 2.6
python3.9dist(ruamel-yaml) >= 0.14.2
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsZstd) <= 5.4.18-1


Content of RPM :
/usr/lib/python3.9/site-packages/strictyaml
/usr/lib/python3.9/site-packages/strictyaml-1.4.0.dist-info
/usr/lib/python3.9/site-packages/strictyaml-1.4.0.dist-info/INSTALLER
/usr/lib/python3.9/site-packages/strictyaml-1.4.0.dist-info/LICENSE.txt
/usr/lib/python3.9/site-packages/strictyaml-1.4.0.dist-info/METADATA
/usr/lib/python3.9/site-packages/strictyaml-1.4.0.dist-info/WHEEL
/usr/lib/python3.9/site-packages/strictyaml-1.4.0.dist-info/top_level.txt
/usr/lib/python3.9/site-packages/strictyaml/__init__.py
/usr/lib/python3.9/site-packages/strictyaml/__pycache__
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/__init__.cpython-39.opt-1.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/__init__.cpython-39.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/any_validator.cpython-39.opt-1.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/any_validator.cpython-39.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/compound.cpython-39.opt-1.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/compound.cpython-39.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/constants.cpython-39.opt-1.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/constants.cpython-39.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/dumper.cpython-39.opt-1.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/dumper.cpython-39.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/exceptions.cpython-39.opt-1.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/exceptions.cpython-39.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/parser.cpython-39.opt-1.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/parser.cpython-39.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/representation.cpython-39.opt-1.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/representation.cpython-39.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/scalar.cpython-39.opt-1.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/scalar.cpython-39.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/utils.cpython-39.opt-1.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/utils.cpython-39.pyc
/usr/lib/python3.9/site-packages/strictyaml/__pycache__/validators.cpython-39.opt-1.pyc
There is 22 files more in these RPM.