SEARCH
NEW RPMS
DIRECTORIES
ABOUT
FAQ
VARIOUS
BLOG
DONATE


YUM REPOSITORY

 
 

php-doctrine-deprecations rpm build for : RedHat EL 7. For other distributions click php-doctrine-deprecations.

Name : php-doctrine-deprecations
Version : 0.5.3 Vendor : Remi's RPM repository < https://rpms_remirepo_net/>
Release : 1.el7.remi Date : 2021-03-30 18:32:59
Group : Unspecified Source RPM : php-doctrine-deprecations-0.5.3-1.el7.remi.src.rpm
Size : 0.01 MB
Packager : Remi Collet
Summary : A small layer on top of trigger_error or PSR-3 logging
Description :
A small (side-effect free by default) layer on top of
trigger_error(E_USER_DEPRECATED) or PSR-3 logging.

* no side-effects by default, making it a perfect fit for libraries
that don\'t know how the error handler works they operate under
* options to avoid having to rely on error handlers global state by
using PSR-3 logging
* deduplicate deprecation messages to avoid excessive triggering and
reduce overhead

We recommend to collect Deprecations using a PSR logger instead of
relying on the global error handler.

Autoloader: /usr/share/php/Doctrine/Deprecations/autoload.php

RPM found in directory: /mirror/rpms.remirepo.net/enterprise/7/remi/armhfp

Content of RPM  Changelog  Provides Requires

Download
ftp.pbone.net  php-doctrine-deprecations-0.5.3-1.el7.remi.noarch.rpm
ftp.pbone.net  php-doctrine-deprecations-0.5.3-1.el7.remi.noarch.rpm
ftp.pbone.net  php-doctrine-deprecations-0.5.3-1.el7.remi.noarch.rpm
     

Provides :
php-composer(doctrine/deprecations)
php-doctrine-deprecations

Requires :
php(language) >= 7.1
php-PsrLog
php-composer(fedora/autoloader)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1


Content of RPM :
/usr/share/doc/php-doctrine-deprecations-0.5.3
/usr/share/doc/php-doctrine-deprecations-0.5.3/README.md
/usr/share/doc/php-doctrine-deprecations-0.5.3/composer.json
/usr/share/php/Doctrine/Deprecations
/usr/share/php/Doctrine/Deprecations/Deprecation.php
/usr/share/php/Doctrine/Deprecations/PHPUnit
/usr/share/php/Doctrine/Deprecations/PHPUnit/VerifyDeprecations.php
/usr/share/php/Doctrine/Deprecations/autoload.php