SEARCH
NEW RPMS
DIRECTORIES
ABOUT
FAQ
VARIOUS
BLOG
DONATE


YUM REPOSITORY

 
 
Changelog for python3-bcrypt-3.2.0-1.10.x86_64.rpm :

* Thu Oct 08 2020 mceplAATTsuse.com- Don\'t use deprecated \'python setup.py test\', use pytest directly.
* Thu Aug 27 2020 adrian.glaubitzAATTsuse.com- Disable Python2 support to fix the build on older distributions
* Thu Aug 20 2020 mimi.vxAATTgmail.com- update to 3.2.0
* add type hints to top level functions
* drop support for python 3.5 and older
* drop legacy code
* Wed May 13 2020 alarrosaAATTsuse.com- Relax the setuptools dependency on 40.8.0 to 40.5.0 since that version is only required by upstream because of a pip issue (see https://github.com/pyca/bcrypt/commit/bc8a55e70e179a59fa89fb109353182f8f438e00). This way we can build in SLE 15 SP2 / Leap 15.2 .
* Sun Jul 28 2019 arunAATTgmx.de- specfile:
* update copyright year
* changed setuptools min version- update to version 3.1.7:
* Set a setuptools lower bound for PEP517 wheel building.
* We no longer distribute 32-bit manylinux1 wheels. Continuing to produce them was a maintenance burden.- changes from version 3.1.6:
* Added support for compilation on Haiku.
* Fri Mar 01 2019 tchvatalAATTsuse.com- Update to 3.1.5:
* Added support for compilation on Haiku.
* Added support for compilation on AIX.
* Dropped Python 2.6 and 3.3 support.
* Switched to using ``abi3`` wheels for Python 3. If you are not getting a wheel on a compatible platform please upgrade your ``pip`` version.
* Wed Aug 29 2018 tchvatalAATTsuse.com- Raise pytest requirement based on setup.py
* Wed Oct 25 2017 arunAATTgmx.de- specfile:
* update copyright year- update to version 3.1.4:
* Fixed compilation with mingw and on illumos.
* Sat May 06 2017 toddrme2178AATTgmail.com- Don\'t provide python2-py-bcrypt, singlespec packages should use correct name.
* Sun Apr 30 2017 jengelhAATTinai.de- Say which crypt methods this module actually supports.
* Sun Apr 30 2017 toddrme2178AATTgmail.com- Update to version 3.1.3
* Fixed a compilation issue on Solaris.
* Added a warning when using too few rounds with kdf.- Update to version 3.1.2
* Fixed a compile issue affecting big endian platforms.
* Fixed invalid escape sequence warnings on Python 3.6.
* Fixed building in non-UTF8 environments on Python 2.- Provides/Obsoletes \"python-py-bcrypt\" exactly.- Change Summary/Description. Apparently \"bcrypt is not \"modern\", not anymore.\"
* Thu Apr 27 2017 toddrme2178AATTgmail.com- Fix license.
* Tue Apr 25 2017 toddrme2178AATTgmail.com- Add Provides/Obsoletes py-bcrypt. This package is intended as a drop-in replacement for py-bcrypt
* Mon Apr 17 2017 axel.braunAATTgmx.de- changes for singlespec
* Wed Oct 05 2016 dmuellerAATTsuse.com- require the cffi version it was built against
* Thu Sep 29 2016 mardnhAATTgmx.de- Update to version 3.1.1
* Resolved a UserWarning when used with cffi 1.8.3.
* Thu Sep 15 2016 mardnhAATTgmx.de- build with \"-fno-strict-aliasing\"
* Sun Sep 11 2016 mardnhAATTgmx.de- initial package, version 3.1.0