SEARCH
NEW RPMS
DIRECTORIES
ABOUT
FAQ
VARIOUS
BLOG
DONATE


YUM REPOSITORY

 
 
Changelog for libthai0-0.1.25-4.2.x86_64.rpm :
Fri Jul 1 14:00:00 2016 zaitorAATTopensuse.org
- Update to version 0.1.25:
+ New word break APIs for more thread-safety.
+ Fix compilation error and warning with GCC 6.
+ Do not test word breaking if dictionary is disabled.
+ Updated word break dictionary.

Mon Nov 30 13:00:00 2015 dimstarAATTopensuse.org
- Update to version 0.1.24:
+ Fix infinite loop caused by optimization in previous version.
(deb#805703).
+ Updated word break dictionary.

Thu Nov 12 13:00:00 2015 zaitorAATTopensuse.org
- Update to version 0.1.23:
+ Correctly check doxygen version on configure.
+ Threadsafe word breaking.
+ Improve word breaking performance by 0.1%.
+ Updated word break dictionary.

Fri May 15 14:00:00 2015 dimstarAATTopensuse.org
- Update to version 0.1.22:
+ Updated word break dictionary.
+ Improve word breaking performance by 0.38%.
+ No timestamp on Doxygen-generated doc.

Sat Aug 23 14:00:00 2014 dimstarAATTopensuse.org
- Update to version 0.1.21:
+ Updated word break dictionary.
+ Improve word breaking performance by 8.61%.

Sun Oct 27 13:00:00 2013 zaitorAATTopensuse.org
- Update to version 0.1.20:
+ Updated word break dictionary.
+ Fix compiler warnings in test suites.

Tue Feb 5 13:00:00 2013 p.drouandAATTgmail.com
- Update to version 0.1.19:
+ New API th_validate_leveled() for IM correction with strictness
level.
+ Updated word break dictionary.
+ Switched to XZ tarball compression.

Mon Jun 18 14:00:00 2012 dimstarAATTopensuse.org
- Update to version 0.1.18:
+ Updated word break dictionary.

Tue Feb 21 13:00:00 2012 vuntzAATTopensuse.org
- Update to version 0.1.17:
+ Recognizes acronyms on word breaking.
+ Updated word break dictionary.

Wed Jan 18 13:00:00 2012 vuntzAATTopensuse.org
- Update to version 0.1.16:
+ Updated word break dictionary.
- Change versioned Obsoletes for libthai from <= to < now that we
have a new upstream version.

Mon Jun 27 14:00:00 2011 dimstarAATTopensuse.org
- Apply SLPP (bnc#674012):
+ Split out libthai0 subpackage
+ Move thbrk.tri in new libthai-data subpackage
+ Add libthai-data Requires to libthai0. This Requires use >=
%{version}, instead of =, since the data is not
parallel-installable with other versions. We can just hope the
data format will stay compatible (and the higher version will
be more complete).
- Change License tag to LGPL-2.1+, as per spdx.org.
- Do not require libdatrie-devel from the -devel package: it will
be added automatically the pkgconfig()-way.
- Adjust baselibs.conf to follow the SLPP name change.
- Change Group of the -devel package to be Development/Languages/C
and C++ instead of System/Libraries.
- Stop using source services. Factory is moving away from it and a
different approach to verify the authenticity of the tarballs is
being implemented (by using the Source URL).
- spec file cleanups.

Fri Apr 29 14:00:00 2011 dimstarAATTopensuse.org
- Update to 0.1.15:
+ Updated word break dictionary.
- Use source services: download_url, recompress, set_version.

Tue Feb 22 13:00:00 2011 vuntzAATTopensuse.org
- Add missing baselibs.conf.

Sun Feb 28 13:00:00 2010 dimstarAATTopensuse.org
- Update to version 0.1.14:
+ Fix crash on corrupted dictionary file; now it fails quietly
instead.
+ License clarification on individual source files.
+ Updated word break dictionary.

Sun Jan 17 13:00:00 2010 vuntzAATTopensuse.org
- Update to version 0.1.13:
+ Fix integer overflow vulnerabilities (CVE-2009-4012).
+ Updated word break dictionary.
- Changes from version 0.1.12:
+ Improved unknown words boundary.
+ Add symbol versioning.
+ Updated word break dictionary.
- Changes from version 0.1.11:
+ Diminished link flags in pkg-config info, for less dependency
for clients.
+ More words in word break dictionary.
- Changes from version 0.1.10:
+ More dictionary capacity with libdatrie 0.2.
+ Dictionary clean-up on unload.
+ Some performance fine-tuning.
+ More words in word break dictionary.
- Drop warnings.patch: fixed upstream.
- Drop bug-569615_01_integer-overflow-vuln.patch: fixed upstream.