SEARCH
NEW RPMS
DIRECTORIES
ABOUT
FAQ
VARIOUS
BLOG
DONATE


YUM REPOSITORY

 
 
Changelog for libopenssl1_0_0-1.0.1u-0.58.1.x86_64.rpm :
Mon Mar 16 13:00:00 2015 vcizekAATTsuse.com
- security update:

* CVE-2015-0209 (bnc#919648)
- Fix a failure to NULL a pointer freed on error

* CVE-2015-0286 (bnc#922496)
- Segmentation fault in ASN1_TYPE_cmp

* CVE-2015-0287 (bnc#922499)
- ASN.1 structure reuse memory corruption

* CVE-2015-0288 x509: (bnc#920236)
- added missing public key is not NULL check

* CVE-2015-0289 (bnc#922500)
- PKCS7 NULL pointer dereferences

* CVE-2015-0292 (bnc#922501)
- Base64 decode

* CVE-2015-0293 (bnc#922488)
- Fix reachable assert in SSLv2 servers

* added patches:
openssl-CVE-2015-0209.patch
openssl-CVE-2015-0286.patch
openssl-CVE-2015-0287.patch
openssl-CVE-2015-0288.patch
openssl-CVE-2015-0289.patch
openssl-CVE-2015-0292.patch
openssl-CVE-2015-0293.patch

Thu Jan 8 13:00:00 2015 vcizekAATTsuse.com
- fix for several security vulnerabilites:

* CVE-2014-3570 (bnc#912296)
- Bignum squaring (BN_sqr) may produce incorrect results on some
platforms, including x86_64.
- added openssl-CVE-2014-3570.patch

* CVE-2014-3571 (bnc#912294)
- Fix crash in dtls1_get_record whilst in the listen state where
you get two separate reads performed - one for the header and
one for the body of the handshake record.
- added openssl-CVE-2014-3571.patch

* CVE-2014-3572 (bnc#912015)
- don\'t accept a handshake using an ephemeral ECDH ciphersuites
with the server key exchange message omitted.
- added openssl-CVE-2014-3572.patch

* CVE-2014-8275 (bnc#912018)
- fix various certificate fingerprint issues
- added openssl-CVE-2014-8275.patch

* CVE-2015-0204 (bnc#912014)
- Only allow ephemeral RSA keys in export ciphersuites
- added openssl-CVE-2015-0204.patch

* CVE-2015-0205 (bnc#912293)
- Fix to prevent use of DH client certificates without sending
certificate verify message.
- added openssl-CVE-2015-0205.patch

* CVE-2015-0206 (bnc#912292)
- memory leak can occur in dtls1_buffer_record
- added openssl-CVE-2015-0206.patch

Tue Nov 25 13:00:00 2014 vcizekAATTsuse.com
- don\'t advertise curves we don\'t support (bnc#906878)

* added openssl-Added-OPENSSL_NO_EC2M-guards-around-the-preferred-EC.patch

Tue Oct 21 14:00:00 2014 vcizekAATTsuse.com
- security fixes for bnc#901277 and bnc#901223
- NOTE: this update alone DOESN\'T FIX the POODLE SSL protocol vulnerability.
OpenSSL only adds downgrade detection support for client applications.
See https://www.suse.com/support/kb/doc.php?id=7015773 for mitigations.
- details of the addressed vulnerabilities:

* ) SRTP Memory Leak.
A flaw in the DTLS SRTP extension parsing code allows an attacker, who
sends a carefully crafted handshake message, to cause OpenSSL to fail
to free up to 64k of memory causing a memory leak. This could be
exploited in a Denial Of Service attack. This issue affects OpenSSL
1.0.1 server implementations for both SSL/TLS and DTLS regardless of
whether SRTP is used or configured. Implementations of OpenSSL that
have been compiled with OPENSSL_NO_SRTP defined are not affected.
(CVE-2014-3513)

* ) Session Ticket Memory Leak.
When an OpenSSL SSL/TLS/DTLS server receives a session ticket the
integrity of that ticket is first verified. In the event of a session
ticket integrity check failing, OpenSSL will fail to free memory
causing a memory leak. By sending a large number of invalid session
tickets an attacker could exploit this issue in a Denial Of Service
attack.
(CVE-2014-3567)

* ) Build option no-ssl3 is incomplete.
When OpenSSL is configured with \"no-ssl3\" as a build option, servers
could accept and complete a SSL 3.0 handshake, and clients could be
configured to send them.
(CVE-2014-3568)

* ) Add support for TLS_FALLBACK_SCSV.
Client applications doing fallback retries should call
SSL_set_mode(s, SSL_MODE_SEND_FALLBACK_SCSV).
(CVE-2014-3566)

Tue Aug 12 14:00:00 2014 meissnerAATTsuse.com
- README.SuSE: document how to build against / with openssl 1.0.1
bnc#889812

Mon Aug 11 14:00:00 2014 vcizekAATTsuse.com
- Double Free when processing DTLS packets (CVE-2014-3505)

* added openssl-CVE-2014-3505.patch

* bnc#890767
- DTLS memory exhaustion (CVE-2014-3506)

* added openssl-CVE-2014-3506.patch

* bnc#890768
- DTLS memory leak from zero-length fragments (CVE-2014-3507)

* added openssl-CVE-2014-3507.patch

* bnc#890769
- Information leak in pretty printing functions (CVE-2014-3508)

* added openssl-CVE-2014-3508.patch

* bnc#890764
- Race condition in ssl_parse_serverhello_tlsext (CVE-2014-3509)

* added openssl-CVE-2014-3509.patch

* bnc#890766
- OpenSSL DTLS anonymous EC(DH) denial of service (CVE-2014-3510)

* added openssl-CVE-2014-3510.patch

* bnc#890770
- TLS protocol downgrade attack (CVE-2014-3511)

* added openssl-CVE-2014-3511.patch

* bnc#890771
- SRP buffer overrun (CVE-2014-3512)

* added openssl-CVE-2014-3512.patch

* bnc#890772
- Crash with SRP ciphersuite in Server Hello message (CVE-2014-5139)

* added openssl-CVE-2014-5139.patch

* bnc#890765

Mon Jun 2 14:00:00 2014 shchangAATTsuse.com
- Fixed bug[ bnc#880891], multiple OpenSSL CVE issues
Add patch files: CVE-2014-3470.patch, CVE-2014-0221.patch, CVE-2014-0224.patch, CVE-2014-0195.patch

Mon May 5 14:00:00 2014 shchangAATTsuse.com
- Fixed bug[ bnc#876282], CVE-2014-0198 openssl: OpenSSL NULL pointer dereference in do_ssl3_write
Add file: CVE-2014-0198.patch

Tue Apr 15 14:00:00 2014 meissnerAATTsuse.com
- use the old SLE11 trust store location, /etc/ssl/certs

Sat Apr 12 14:00:00 2014 shchangAATTsuse.com
- Fixed bug[ bnc#873351] CVE-2010-5298: openssl: Use-after-free race condition,in OpenSSL\'s read buffer
Add file: CVE-2010-5298.patch

Fri Apr 11 14:00:00 2014 meissnerAATTsuse.com
- updated to 1.0.1g stable version.
Includes fixes for:
- CVE-2014-0160: remote memory disclosure aka \"The HeartBleed attack\".
- CVE-2014-0076: Recovering OpenSSL ECDSA Nonces Using the FLUSH+RELOAD
Cache Side-channel Attack
- openssl1.keyring: tarballs now signed by Dr. Stephen Henssons 4096bit key.

Mon Apr 7 14:00:00 2014 meissnerAATTsuse.com
- openssl-CVE-2014-0160-TLS-heartbeat-read-overrun.patch:
Fixed a remote memory disclosure via missing boundary checks in
TLS heartbeat, bnc#872299 / CVE-2014-0160

Tue Jan 28 13:00:00 2014 meissnerAATTsuse.com
- Adapted the SLE12 openssl 1.0.1f for usage in SLE11.
(FATE#316898 / bnc#861014 / bnc#864912)
- FIPS work is disabled for now as its not yet finished
- engines moved to /engines1/ directory to avoid conflicts.
- libopenssl1_0_0 shared library package, with engines
in /engines1/ directory.
- libopenssl1-devel package (conflicting with libopenssl-devel)
- openssl1 package that can coexist alongside openssl
package with \"openssl1\" commandline tool.
- Use c_rehash1 for generating openssl1 and openssl0 compatible hashes.
- bug-860332-cmdline-check-certs.patch: check /etc/ssl/certs
by default in the commandline tool. (bnc#860332)
- Fix bug[ bnc#869945] CVE-2014-0076: openssl: Recovering OpenSSL ECDSA
Nonces Using the FLUSH+RELOAD Cache Side-channel Attack
Add file: CVE-2014-0076.patch

Thu Jan 9 13:00:00 2014 andreas.stiegerAATTgmx.de
- 1.0.1f:

* Fix for TLS record tampering bug CVE-2013-4353
- already included:

* Fix for TLS version checking bug CVE-2013-6449

* Fix for DTLS retransmission bug CVE-2013-6450
- removed patches:

* CVE-2013-6449.patch, committed upstream

* CVE-2013-6450.patch, committed upstream

* SSL_get_certificate-broken.patch, committed upstream

* openssl-1.0.1e-bnc822642.patch, committed upstream
- modified patches:

* openssl-1.0.1e-fips.patch, adjust for upstream changes

* openssl-fix-pod-syntax.diff, adjust for upstream changes

Wed Jan 8 13:00:00 2014 andreas.stiegerAATTgmx.de
- add a gpg keyring for source tarball

Wed Jan 8 13:00:00 2014 shchangAATTsuse.com
- Fixed bnc#857850, openssl doesn\'t load engine
Modify file: openssl.spec

Thu Jan 2 13:00:00 2014 shchangAATTsuse.com
- Fixed bnc#857203, openssl: crash in DTLS renegotiation after packet loss
Add file: CVE-2013-6450.patch

Sun Dec 22 13:00:00 2013 shchangAATTsuse.com
- Fixed bnc#856687, openssl: crash when using TLS 1.2
Add file: CVE-2013-6449.patch

Tue Dec 17 13:00:00 2013 meissnerAATTsuse.com
- compression_methods_switch.patch: setenv might not be successful
if a surrounding library or application filters it, like e.g. sudo.
As setenv() does not seem to be useful anyway, remove it.
bnc#849377

Mon Dec 16 13:00:00 2013 shchangAATTsuse.com
- Adjust the installation path.
Modify files: README-FIPS.txt openssl.spec

Fri Dec 6 13:00:00 2013 lnusselAATTsuse.de
- don\'t own /etc/ssl/certs, it\'s owned by ca-certificates

Tue Dec 3 13:00:00 2013 meissnerAATTsuse.com
- Actually enable it (in a building way) for openSUSE and SLES,
as we intended.
- Add README-FIPS.txt from SLE 11.

Mon Dec 2 13:00:00 2013 crrodriguezAATTopensuse.org
- Restrict the (broken beyond build) FIPS certification code
to SLE releases only, it has no value in openSUSE at all.

Sat Nov 23 13:00:00 2013 shchangAATTsuse.com
- Patches for OpenSSL FIPS-140-2/3 certification
Add patch files: openssl-1.0.1e-fips.patch, openssl-1.0.1e-fips-ec.patch,
openssl-1.0.1e-fips-ctor.patch

Wed Oct 23 14:00:00 2013 crrodriguezAATTopensuse.org
- 0001-libcrypto-Hide-library-private-symbols.patch
This patch implements the libcrpto part complimentary to
0005-libssl-Hide-library-private-symbols.patch.
This patch is however not 100% complete, as some private library
symbols are declared in public headers that shall not be touched
or are defined/declared in \"perlasm\". (tested in 13.1, 12.3, factory)
- openSSL defaults to -O3 optimization level but we override
it with RPM_OPT_FLAGS, ensure we use -O3 like upstream.

Fri Oct 11 14:00:00 2013 meissnerAATTsuse.com
- openssl-1.0.1c-ipv6-apps.patch:
Support ipv6 in the openssl s_client / s_server commandline app.

Fri Sep 27 14:00:00 2013 dmacvicarAATTsuse.de
- VPN openconnect problem (DTLS handshake failed)
(git 9fe4603b8, bnc#822642, openssl ticket#2984)

Wed Sep 4 14:00:00 2013 guillaumeAATTopensuse.org
- Fix armv6l arch (armv7 was previously used to build armv6 which
lead to illegal instruction when used)

Mon Aug 12 14:00:00 2013 shchangAATTsuse.com
- Fix bug[ bnc#832833] openssl ssl_set_cert_masks() is broken
modify patch file: SSL_get_certificate-broken.patch

Fri Aug 9 14:00:00 2013 crrodriguezAATTopensuse.org
- Via padlock is only found in x86 and x86_64 CPUs, remove
the shared module for other archs.

Wed Aug 7 14:00:00 2013 crrodriguezAATTopensuse.org
- Cleanup engines that are of no use in a modern linux distro
- The following engines stay:

* libcapi.so --> usable in case you have third party /dev/crypto

* libgmp.so --> may help to doing some maths using GMP

* libgost.so --> implements the GOST block cipher

* libpadlock.so --> VIA padlock support
- Al other are removed because they require third party propietary
shared libraries nowhere to be found or that we can test.

Wed Aug 7 14:00:00 2013 crrodriguezAATTopensuse.org
- openssl-pkgconfig.patch: Here we go.. For applications
to benefit fully of features provided by openSSL engines
(rdrand, aes-ni..etc) either builtin or in DSO form applications
have to call ENGINE_load_builtin_engines() or OPENSSL_config()
unfortunately from a total of 68 apps/libraries linked to libcrypto
in a desktop system, only 4 do so, and there is a sea of buggy
code that I dont feel like fixing.
Instead we can pass -DOPENSSL_LOAD_CONF in the pkgconfig files
so the needed operation becomes implicit the next time such apps
are recompiled, see OPENSSL_config(3)
Unfortunately this does not fix everything, because there are apps
not using pkgconfig or using it incorrectly, but it is a good start.

Wed Aug 7 14:00:00 2013 dmuellerAATTsuse.com
- add openssl-1.0.1c-default-paths.patch:
Fix from Fedora for openssl s_client not setting
CApath by default

Sat Aug 3 14:00:00 2013 crrodriguezAATTopensuse.org
- 0005-libssl-Hide-library-private-symbols.patch: hide
private symbols, this
*only
* applies to libssl where
it is straightforward to do so as applications should
not be using any of the symbols declared/defined in headers
that the library does not install.
A separate patch MAY be provided in the future for libcrypto
where things are much more complicated and threfore requires
careful testing.

Mon Jul 29 14:00:00 2013 meissnerAATTsuse.com
- compression_methods_switch.patch: Disable compression by default to
avoid the CRIME attack (CVE-2012-4929 bnc#793420)
Can be override by setting environment variable
OPENSSL_NO_DEFAULT_ZLIB=no

Tue Jul 2 14:00:00 2013 lnusselAATTsuse.de
- Don\'t use the legacy /etc/ssl/certs directory anymore but rather
the p11-kit generated /var/lib/ca-certificates/openssl one
(fate#314991, openssl-1.0.1e-truststore.diff)

Sat Jun 29 14:00:00 2013 crrodriguezAATTopensuse.org
- Build enable-ec_nistp_64_gcc_128, ecdh is many times faster
but only works in x86_64.
According to the openSSL team
\"it is superior to the default in multiple regards (speed, and also
security as the new implementations are secure against timing
attacks)\"
It is not enabled by default due to the build system being unable
to detect if the compiler supports __uint128_t.

Thu Jun 20 14:00:00 2013 cooloAATTsuse.com
- pick openssl-fix-pod-syntax.diff out of the upstream RT to fix
build with perl 5.18

Sat May 25 14:00:00 2013 iAATTmarguerite.su
- add %if tag for BuildArch. sles may also need latest openssl.

Fri Feb 22 13:00:00 2013 dmuellerAATTsuse.com
- disable fstack-protector on aarch64

Tue Feb 12 13:00:00 2013 hrvoje.senjanAATTgmail.com
- Update to 1.0.1e
o Bugfix release (bnc#803004)
- Drop openssl-1.0.1d-s3-packet.patch, included upstream

Sun Feb 10 13:00:00 2013 hrvoje.senjanAATTgmail.com
- Added openssl-1.0.1d-s3-packet.patch from upstream, fixes
bnc#803004, openssl ticket#2975

Tue Feb 5 13:00:00 2013 meissnerAATTsuse.com
- update to version 1.0.1d, fixing security issues
o Fix renegotiation in TLS 1.1, 1.2 by using the correct TLS version.
o Include the fips configuration module.
o Fix OCSP bad key DoS attack CVE-2013-0166
o Fix for SSL/TLS/DTLS CBC plaintext recovery attack CVE-2013-0169
bnc#802184
o Fix for TLS AESNI record handling flaw CVE-2012-2686

Mon Nov 12 13:00:00 2012 gjheAATTsuse.com
- fix bug[bnc#784994] - VIA padlock support on 64 systems
e_padlock: add support for x86_64 gcc

Sun Aug 19 14:00:00 2012 crrodriguezAATTopensuse.org
- Open Internal file descriptors with O_CLOEXEC, leaving
those open across fork()..execve() makes a perfect
vector for a side-channel attack...

Tue Aug 7 14:00:00 2012 dmuellerAATTsuse.com
- fix build on armv5 (bnc#774710)

Thu May 10 14:00:00 2012 crrodriguezAATTopensuse.org
- Update to version 1.0.1c for the complete list of changes see
NEWS, this only list packaging changes.
- Drop aes-ni patch, no longer needed as it is builtin in openssl
now.
- Define GNU_SOURCE and use -std=gnu99 to build the package.
- Use LFS_CFLAGS in platforms where it matters.

Fri May 4 14:00:00 2012 lnusselAATTsuse.de
- don\'t install any demo or expired certs at all

Mon Apr 23 14:00:00 2012 gjheAATTsuse.com
- update to latest stable verison 1.0.0i
including the following patches:
CVE-2012-2110.path
Bug748738_Tolerate_bad_MIME_headers.patch
bug749213-Free-headers-after-use.patch
bug749210-Symmetric-crypto-errors-in-PKCS7_decrypt.patch
CVE-2012-1165.patch
CVE-2012-0884.patch
bug749735.patch

Tue Mar 27 14:00:00 2012 gjheAATTsuse.com
- fix bug[bnc#749735] - Memory leak when creating public keys.
fix bug[bnc#751977] - CMS and S/MIME Bleichenbacher attack
CVE-2012-0884

Thu Mar 22 13:00:00 2012 gjheAATTsuse.com
- fix bug[bnc#751946] - S/MIME verification may erroneously fail
CVE-2012-1165

Wed Mar 21 13:00:00 2012 gjheAATTsuse.com
- fix bug[bnc#749213]-Free headers after use in error message
and bug[bnc#749210]-Symmetric crypto errors in PKCS7_decrypt

Tue Mar 20 13:00:00 2012 cfarrellAATTsuse.com
- license update: OpenSSL

Fri Feb 24 13:00:00 2012 gjheAATTsuse.com
- fix bug[bnc#748738] - Tolerate bad MIME headers in openssl\'s
asn1 parser.
CVE-2006-7250

Thu Feb 2 13:00:00 2012 gjheAATTsuse.com
- Update to version 1.0.0g fix the following:
DTLS DoS attack (CVE-2012-0050)

Wed Jan 11 13:00:00 2012 gjheAATTsuse.com
- Update to version 1.0.0f fix the following:
DTLS Plaintext Recovery Attack (CVE-2011-4108)
Uninitialized SSL 3.0 Padding (CVE-2011-4576)
Malformed RFC 3779 Data Can Cause Assertion Failures (CVE-2011-4577)
SGC Restart DoS Attack (CVE-2011-4619)
Invalid GOST parameters DoS Attack (CVE-2012-0027)

Tue Oct 18 14:00:00 2011 crrodriguezAATTopensuse.org
- AES-NI: Check the return value of Engine_add()
if the ENGINE_add() call fails: it ends up adding a reference
to a freed up ENGINE which is likely to subsequently contain garbage
This will happen if an ENGINE with the same name is added multiple
times,for example different libraries. [bnc#720601]

Sat Oct 8 14:00:00 2011 crrodriguezAATTopensuse.org
- Build with -DSSL_FORBID_ENULL so servers are not
able to use the NULL encryption ciphers (Those offering no
encryption whatsoever).

Wed Sep 7 14:00:00 2011 crrodriguezAATTopensuse.org
- Update to openssl 1.0.0e fixes CVE-2011-3207 and CVE-2011-3210
see http://openssl.org/news/secadv_20110906.txt for details.

Sat Aug 6 14:00:00 2011 crrodriguezAATTopensuse.org
- Add upstream patch that calls ENGINE_register_all_complete()
in ENGINE_load_builtin_engines() saving us from adding dozens
of calls to such function to calling applications.

Fri Aug 5 14:00:00 2011 crrodriguezAATTopensuse.org
- remove -fno-strict-aliasing from CFLAGS no longer needed
and is likely to slow down stuff.

Mon Jul 25 14:00:00 2011 jengelhAATTmedozas.de
- Edit baselibs.conf to provide libopenssl-devel-32bit too

Fri Jun 24 14:00:00 2011 gjheAATTnovell.com
- update to latest stable version 1.0.0d.
patch removed(already in the new package):
CVE-2011-0014
patch added:
ECDSA_signatures_timing_attack.patch

Tue May 31 14:00:00 2011 gjheAATTnovell.com
- fix bug[bnc#693027].
Add protection against ECDSA timing attacks as mentioned in the paper
by Billy Bob Brumley and Nicola Tuveri, see:
http://eprint.iacr.org/2011/232.pdf
[Billy Bob Brumley and Nicola Tuveri]

Mon May 16 14:00:00 2011 andreaAATTopensuse.org
- added openssl as dependency in the devel package

Thu Feb 10 13:00:00 2011 gjheAATTnovell.com
- fix bug [bnc#670526]
CVE-2011-0014,OCSP stapling vulnerability

Sat Jan 15 13:00:00 2011 cristian.rodriguezAATTopensuse.org
- Add patch from upstream in order to support AES-NI instruction
set present on current Intel and AMD processors

Mon Jan 10 13:00:00 2011 meissnerAATTsuse.de
- enable -DPURIFY to avoid valgrind errors.

Thu Dec 9 13:00:00 2010 gjheAATTnovell.com
- update to stable version 1.0.0c.
patch included:
CVE-2010-1633_and_CVE-2010-0742.patch
patchset-19727.diff
CVE-2010-2939.patch
CVE-2010-3864.patch

Thu Nov 18 13:00:00 2010 gjheAATTnovell.com
- fix bug [bnc#651003]
CVE-2010-3864

Sat Sep 25 14:00:00 2010 gjheAATTnovell.com
- fix bug [bnc#629905]
CVE-2010-2939

Wed Jul 28 14:00:00 2010 cristian.rodriguezAATTopensuse.org
- Exclude static libraries, see what breaks and fix that
instead

Wed Jun 30 14:00:00 2010 jengelhAATTmedozas.de
- fix two compile errors on SPARC

Tue Jun 15 14:00:00 2010 bgAATTnovell.com
- -fstack-protector is not supported on hppa

Fri Jun 4 14:00:00 2010 gjheAATTnovell.com
- fix bnc #610642
CVE-2010-0742
CVE-2010-1633

Mon May 31 14:00:00 2010 gjheAATTnovell.com
- fix bnc #610223,change Configure to tell openssl to load engines
from /%{_lib} instead of %{_libdir}

Mon May 10 14:00:00 2010 ajAATTsuse.de
- Do not compile in build time but use mtime of changes file instead.
This allows build-compare to identify that no changes have happened.

Tue May 4 14:00:00 2010 gjheAATTnovell.com
- build libopenssl to /%{_lib} dir,and keep only one
libopenssl-devel for new developping programs.

Tue Apr 27 14:00:00 2010 gjheAATTnovell.com
- build libopenssl and libopenssl-devel to a version directory

Sat Apr 24 14:00:00 2010 cooloAATTnovell.com
- buildrequire pkg-config to fix provides

Wed Apr 21 14:00:00 2010 lnusselAATTsuse.de
- also create old certificate hash in /etc/ssl/certs for
compatibility with applications that still link against 0.9.8

Mon Apr 12 14:00:00 2010 meissnerAATTsuse.de
- Disable our own build targets, instead use the openSSL provided ones
as they are now good (or should be good at least).
- add -Wa,--noexecstack to the Configure call, this is the upstream
approved way to avoid exec-stack marking

Mon Apr 12 14:00:00 2010 gjheAATTnovell.com
- update to 1.0.0
Merge the following patches from 0.9.8k:
openssl-0.9.6g-alpha.diff
openssl-0.9.7f-ppc64.diff
openssl-0.9.8-flags-priority.dif
openssl-0.9.8-sparc.dif
openssl-allow-arch.diff
openssl-hppa-config.diff

Fri Apr 9 14:00:00 2010 meissnerAATTsuse.de
- fixed \"exectuable stack\" for libcrypto.so issue on i586 by
adjusting the assembler output during MMX builds.

Wed Apr 7 14:00:00 2010 meissnerAATTsuse.de
- Openssl is now partially converted to libdir usage upstream,
merge that in to fix lib64 builds.

Thu Mar 25 13:00:00 2010 gjheAATTnovell.com
- fix security bug [bnc#590833]
CVE-2010-0740

Mon Mar 22 13:00:00 2010 gjheAATTnovell.com
- update to version 0.9.8m
Merge the following patches from 0.9.8k:
bswap.diff
non-exec-stack.diff
openssl-0.9.6g-alpha.diff
openssl-0.9.7f-ppc64.diff
openssl-0.9.8-flags-priority.dif
openssl-0.9.8-sparc.dif
openssl-allow-arch.diff
openssl-hppa-config.diff

Fri Feb 5 13:00:00 2010 jengelhAATTmedozas.de
- build openssl for sparc64

Mon Dec 14 13:00:00 2009 jengelhAATTmedozas.de
- add baselibs.conf as a source
- package documentation as noarch

Tue Nov 3 13:00:00 2009 cooloAATTnovell.com
- updated patches to apply with fuzz=0

Tue Sep 1 14:00:00 2009 gjheAATTnovell.com
- fix Bug [bnc#526319]

Wed Aug 26 14:00:00 2009 cooloAATTnovell.com
- use %patch0 for Patch0

Fri Jul 3 14:00:00 2009 gjheAATTnovell.com
- update to version 0.9.8k
- patches merged upstream:
openssl-CVE-2008-5077.patch
openssl-CVE-2009-0590.patch
openssl-CVE-2009-0591.patch
openssl-CVE-2009-0789.patch
openssl-CVE-2009-1377.patch
openssl-CVE-2009-1378.patch
openssl-CVE-2009-1379.patch
openssl-CVE-2009-1386.patch
openssl-CVE-2009-1387.patch

Tue Jun 30 14:00:00 2009 gjheAATTnovell.com
- fix security bug [bnc#509031]
CVE-2009-1386
CVE-2009-1387

Tue Jun 30 14:00:00 2009 gjheAATTnovell.com
- fix security bug [bnc#504687]
CVE-2009-1377
CVE-2009-1378
CVE-2009-1379

Wed Apr 15 14:00:00 2009 gjheAATTsuse.de
- fix security bug [bnc#489641]
CVE-2009-0590
CVE-2009-0591
CVE-2009-0789

Wed Jan 7 13:00:00 2009 olhAATTsuse.de
- obsolete old -XXbit packages (bnc#437293)

Thu Dec 18 13:00:00 2008 jshiAATTsuse.de
- fix security bug [bnc#459468]
CVE-2008-5077

Tue Dec 9 13:00:00 2008 xwhuAATTsuse.de
- Disable optimization for s390x

Mon Dec 8 13:00:00 2008 xwhuAATTsuse.de
- Disable optimization of md4

Mon Nov 10 13:00:00 2008 xwhuAATTsuse.de
- Disable optimization of ripemd [bnc#442740]

Tue Oct 14 14:00:00 2008 xwhuAATTsuse.de
- Passing string as struct cause openssl segment-fault [bnc#430141]

Wed Jul 16 14:00:00 2008 mkoenigAATTsuse.de
- do not require openssl-certs, but rather recommend it
to avoid dependency cycle [bnc#408865]

Wed Jul 9 14:00:00 2008 mkoenigAATTsuse.de
- remove the certs subpackage from the openssl package
and move the CA root certificates into a package of its own

Tue Jun 24 14:00:00 2008 mkoenigAATTsuse.de
- update to version 0.9.8h
- openssl does not ship CA root certificates anymore
keep certificates that SuSE is already shipping
- resolves bad array index (function has been removed) [bnc#356549]
- removed patches
openssl-0.9.8g-fix_dh_for_certain_moduli.patch
openssl-CVE-2008-0891.patch
openssl-CVE-2008-1672.patch

Wed May 28 14:00:00 2008 mkoenigAATTsuse.de
- fix OpenSSL Server Name extension crash (CVE-2008-0891)
and OpenSSL Omit Server Key Exchange message crash (CVE-2008-1672)
[bnc#394317]

Wed May 21 14:00:00 2008 cthielAATTsuse.de
- fix baselibs.conf

Tue Apr 22 14:00:00 2008 mkoenigAATTsuse.de
- add -DMD32_REG_T=int for x86_64 and ia64 [bnc#381844]

Thu Apr 10 14:00:00 2008 roAATTsuse.de
- added baselibs.conf file to build xxbit packages
for multilib support

Mon Nov 5 13:00:00 2007 mkoenigAATTsuse.de
- fix Diffie-Hellman failure with certain prime lengths

Mon Oct 22 14:00:00 2007 mkoenigAATTsuse.de
- update to version 0.9.8g:

* fix some bugs introduced with 0.9.8f

Mon Oct 15 14:00:00 2007 mkoenigAATTsuse.de
- update to version 0.9.8f:

* fixes CVE-2007-3108, CVE-2007-5135, CVE-2007-4995
- patches merged upstream:
openssl-0.9.8-key_length.patch
openssl-CVE-2007-3108-bug296511
openssl-CVE-2007-5135.patch
openssl-gcc42.patch
openssl-gcc42_b.patch
openssl-s390-config.diff

Mon Oct 1 14:00:00 2007 mkoenigAATTsuse.de
- fix buffer overflow CVE-2007-5135 [#329208]

Wed Sep 5 14:00:00 2007 mkoenigAATTsuse.de
- fix another gcc 4.2 build problem [#307669]

Fri Aug 3 14:00:00 2007 cooloAATTsuse.de
- provide the version obsoleted (#293401)

Wed Aug 1 14:00:00 2007 wernerAATTsuse.de
- Add patch from CVS for RSA key reconstruction vulnerability
(CVE-2007-3108, VU#724968, bug #296511)

Thu May 24 14:00:00 2007 mkoenigAATTsuse.de
- fix build with gcc-4.2
openssl-gcc42.patch
- do not install example scripts with executable permissions

Sun Apr 29 14:00:00 2007 roAATTsuse.de
- adapt requires

Fri Apr 27 14:00:00 2007 mkoenigAATTsuse.de
- Do not use dots in package name
- explicitly build with gcc-4.1 because of currently unresolved
failures with gcc-4.2

Wed Apr 25 14:00:00 2007 mkoenigAATTsuse.de
- Split/rename package to follow library packaging policy [#260219]
New package libopenssl0.9.8 containing shared libs
openssl-devel package renamed to libopenssl-devel
New package openssl-certs containing certificates
- add zlib-devel to Requires of devel package
- remove old Obsoletes and Conflicts
openssls (Last used Nov 2000)
ssleay (Last used 6.2)

Mon Apr 23 14:00:00 2007 mkoenigAATTsuse.de
- Fix key length [#254905,#262477]

Tue Mar 6 13:00:00 2007 mkoenigAATTsuse.de
- update to version 0.9.8e:

* patches merged upstream:
openssl-CVE-2006-2940-fixup.patch
openssl-0.9.8d-padlock-static.patch

Tue Jan 9 13:00:00 2007 mkoenigAATTsuse.de
- fix PadLock support [#230823]

Thu Nov 30 13:00:00 2006 mkoenigAATTsuse.de
- enable fix for CVE-2006-2940 [#223040], SWAMP-ID 7198

Mon Nov 6 13:00:00 2006 poemlAATTsuse.de
- configure with \'zlib\' instead of \'zlib-dynamic\'. Build with the
latter, there are problems opening the libz when running on the
Via Epia or vmware platforms. [#213305]

Wed Oct 4 14:00:00 2006 poemlAATTsuse.de
- add patch for the CVE-2006-2940 fix: the newly introduced limit
on DH modulus size could lead to a crash when exerted. [#208971]
Discovered and fixed after the 0.9.8d release.

Fri Sep 29 14:00:00 2006 poemlAATTsuse.de
- update to 0.9.8d

* ) Introduce limits to prevent malicious keys being able to
cause a denial of service. (CVE-2006-2940)

* ) Fix ASN.1 parsing of certain invalid structures that can result
in a denial of service. (CVE-2006-2937)

* ) Fix buffer overflow in SSL_get_shared_ciphers() function.
(CVE-2006-3738)

* ) Fix SSL client code which could crash if connecting to a
malicious SSLv2 server. (CVE-2006-4343)

* ) Since 0.9.8b, ciphersuite strings naming explicit ciphersuites
match only those. Before that, \"AES256-SHA\" would be interpreted
as a pattern and match \"AES128-SHA\" too (since AES128-SHA got
the same strength classification in 0.9.7h) as we currently only
have a single AES bit in the ciphersuite description bitmap.
That change, however, also applied to ciphersuite strings such as
\"RC4-MD5\" that intentionally matched multiple ciphersuites --
namely, SSL 2.0 ciphersuites in addition to the more common ones
from SSL 3.0/TLS 1.0.
So we change the selection algorithm again: Naming an explicit
ciphersuite selects this one ciphersuite, and any other similar
ciphersuite (same bitmap) from
*other
* protocol versions.
Thus, \"RC4-MD5\" again will properly select both the SSL 2.0
ciphersuite and the SSL 3.0/TLS 1.0 ciphersuite.
Since SSL 2.0 does not have any ciphersuites for which the
128/256 bit distinction would be relevant, this works for now.
The proper fix will be to use different bits for AES128 and
AES256, which would have avoided the problems from the beginning;
however, bits are scarce, so we can only do this in a new release
(not just a patchlevel) when we can change the SSL_CIPHER
definition to split the single \'unsigned long mask\' bitmap into
multiple values to extend the available space.
- not in mentioned in CHANGES: patch for CVE-2006-4339 corrected
[openssl.org #1397]

Fri Sep 8 14:00:00 2006 schwabAATTsuse.de
- Fix inverted logic.

Wed Sep 6 14:00:00 2006 poemlAATTsuse.de
- update to 0.9.8c
Changes between 0.9.8b and 0.9.8c [05 Sep 2006]

* ) Avoid PKCS #1 v1.5 signature attack discovered by Daniel Bleichenbacher
(CVE-2006-4339) [Ben Laurie and Google Security Team]

* ) Add AES IGE and biIGE modes. [Ben Laurie]

* ) Change the Unix randomness entropy gathering to use poll() when
possible instead of select(), since the latter has some
undesirable limitations. [Darryl Miles via Richard Levitte and Bodo Moeller]

* ) Disable \"ECCdraft\" ciphersuites more thoroughly. Now special
treatment in ssl/ssl_ciph.s makes sure that these ciphersuites
cannot be implicitly activated as part of, e.g., the \"AES\" alias.
However, please upgrade to OpenSSL 0.9.9[-dev] for
non-experimental use of the ECC ciphersuites to get TLS extension
support, which is required for curve and point format negotiation
to avoid potential handshake problems. [Bodo Moeller]

* ) Disable rogue ciphersuites:
- SSLv2 0x08 0x00 0x80 (\"RC4-64-MD5\")
- SSLv3/TLSv1 0x00 0x61 (\"EXP1024-RC2-CBC-MD5\")
- SSLv3/TLSv1 0x00 0x60 (\"EXP1024-RC4-MD5\")
The latter two were purportedly from
draft-ietf-tls-56-bit-ciphersuites-0[01].txt, but do not really
appear there.
Also deactive the remaining ciphersuites from
draft-ietf-tls-56-bit-ciphersuites-01.txt. These are just as
unofficial, and the ID has long expired. [Bodo Moeller]

* ) Fix RSA blinding Heisenbug (problems sometimes occured on
dual-core machines) and other potential thread-safety issues.
[Bodo Moeller]

* ) Add the symmetric cipher Camellia (128-bit, 192-bit, 256-bit key
versions), which is now available for royalty-free use
(see http://info.isl.ntt.co.jp/crypt/eng/info/chiteki.html).
Also, add Camellia TLS ciphersuites from RFC 4132.
To minimize changes between patchlevels in the OpenSSL 0.9.8
series, Camellia remains excluded from compilation unless OpenSSL
is configured with \'enable-camellia\'. [NTT]

* ) Disable the padding bug check when compression is in use. The padding
bug check assumes the first packet is of even length, this is not
necessarily true if compresssion is enabled and can result in false
positives causing handshake failure. The actual bug test is ancient
code so it is hoped that implementations will either have fixed it by
now or any which still have the bug do not support compression.
[Steve Henson]
Changes between 0.9.8a and 0.9.8b [04 May 2006]

* ) When applying a cipher rule check to see if string match is an explicit
cipher suite and only match that one cipher suite if it is. [Steve Henson]

* ) Link in manifests for VC++ if needed. [Austin Ziegler ]

* ) Update support for ECC-based TLS ciphersuites according to
draft-ietf-tls-ecc-12.txt with proposed changes (but without
TLS extensions, which are supported starting with the 0.9.9
branch, not in the OpenSSL 0.9.8 branch). [Douglas Stebila]

* ) New functions EVP_CIPHER_CTX_new() and EVP_CIPHER_CTX_free() to support
opaque EVP_CIPHER_CTX handling. [Steve Henson]

* ) Fixes and enhancements to zlib compression code. We now only use
\"zlib1.dll\" and use the default __cdecl calling convention on Win32
to conform with the standards mentioned here:
http://www.zlib.net/DLL_FAQ.txt
Static zlib linking now works on Windows and the new --with-zlib-include
- -with-zlib-lib options to Configure can be used to supply the location
of the headers and library. Gracefully handle case where zlib library
can\'t be loaded. [Steve Henson]

* ) Several fixes and enhancements to the OID generation code. The old code
sometimes allowed invalid OIDs (1.X for X >= 40 for example), couldn\'t
handle numbers larger than ULONG_MAX, truncated printing and had a
non standard OBJ_obj2txt() behaviour. [Steve Henson]

* ) Add support for building of engines under engine/ as shared libraries
under VC++ build system. [Steve Henson]

* ) Corrected the numerous bugs in the Win32 path splitter in DSO.
Hopefully, we will not see any false combination of paths any more.
[Richard Levitte]
- enable Camellia cipher. There is a royalty free license to the
patents, see http://info.isl.ntt.co.jp/crypt/eng/info/chiteki.html.
NOTE: the license forbids patches to the cipher.
- build with zlib-dynamic and add zlib-devel to BuildRequires.
Allows compression of data in TLS, although few application would
actually use it since there is no standard for negotiating the
compression method. The only one I know if is stunnel.