SEARCH
NEW RPMS
DIRECTORIES
ABOUT
FAQ
VARIOUS
BLOG
DONATE


YUM REPOSITORY

 
 
Changelog for libruby2_5-2_5-2.5.3-lp150.60.1.x86_64.rpm :

* Thu Feb 07 2019 Marcus Rueckert - replace the awk based provides generation with the new file-attr handler in ruby-bundled-gems-rpmhelper This kills one provides rubygem-name = version But this should not have be used since a while anymore.- add option to build without docs for testing- provide support to undo the split of the stdlib: pass --without=separate_stdlib to \"osc build\"
* Fri Nov 23 2018 Martin Liška - Use parallel make.
* Thu Nov 22 2018 Martin Liška - Disable compressed sections as they are not supported by rpm (https://bugs.ruby-lang.org/issues/12934).
* Wed Nov 07 2018 Marcus Rueckert - update to 2.5.3 This release includes some bug fixes and some security fixes. - CVE-2018-16396: Tainted flags are not propagated in Array#pack and String#unpack with some directives - CVE-2018-16395: OpenSSL::X509::Name equality check does not work correctly https://github.com/ruby/ruby/compare/v2_5_1...v2_5_3- drop frozen-pop3.patch
* Tue Oct 16 2018 Marcus Rueckert - backport 450160263aed8c446ce5b142d71f921ab4118f3a.patch: Include the alternative malloc header instead of malloc.h
* Tue Aug 28 2018 Marcus Rueckert - update to 2.5.1 This release includes some bug fixes and some security fixes. - CVE-2017-17742: HTTP response splitting in WEBrick - CVE-2018-6914: Unintentional file and directory creation with directory traversal in tempfile and tmpdir - CVE-2018-8777: DoS by large request in WEBrick - CVE-2018-8778: Buffer under-read in String#unpack - CVE-2018-8779: Unintentional socket creation by poisoned NUL byte in UNIXServer and UNIXSocket - CVE-2018-8780: Unintentional directory traversal by poisoned NUL byte in Dir - Multiple vulnerabilities in RubyGems https://github.com/ruby/ruby/compare/v2_5_0...v2_5_1
* Tue Aug 28 2018 Marcus Rueckert - added frozen-pop3.patch: Net::POPMail methods modify frozen literal when using default arg https://redmine.ruby-lang.org/issues/14416
* Thu Mar 22 2018 mrueckertAATTsuse.de- wrong files where installed from the macro files after adding dump-version.rb
* Thu Jan 25 2018 mrueckertAATTsuse.de- fix dump-versions.rb: it was picking up system rdoc versions on some source dirs
* Mon Jan 15 2018 mrueckertAATTsuse.de- add reproducible build patches from debian 0003-Mark-Gemspec-reproducible-change-fixing-784225-too.patch 0004-Make-gemspecs-reproducible.patch
* Mon Dec 25 2017 mrueckertAATTsuse.de- drop 316f58076d29dcff053256992d9ec19fed7e698f.patch- no longer bundling bundler
* Mon Dec 25 2017 mrueckertAATTsuse.de- update to 2.5.0 final Ruby 2.5.0 is the first stable release of the Ruby 2.5 series. It introduces many new features and performance improvements. The notable changes are as follows: - New Features - rescue/else/ensure are now allowed to be used directly with do/end blocks. [Feature #12906] - Add yield_self to yield given block in its context. Unlike tap, it returns the result of the block. [Feature #6721] - Support branch coverage and method coverage measurement. The branch coverage indicates which branches are executed and which are not. The method coverage indicates which methods are invoked and which are not. By running the test suite with these new features, you will know which branches and methods are executed, and evaluate total coverage of the test suite more strictly. [Feature #13901] - Hash#slice [Feature #8499] and Hash#transform_keys [Feature [#13583]] - Struct.new can create classes that accept keyword arguments. [Feature #11925] - Enumerable#any?,all?,none? and one? accept a pattern argument [Feature #11286] - Top-level constant look-up is no longer available. [Feature [#11547]] - One of our most loved libraries, pp.rb, is now automatically loaded. You no longer have to write require \"pp\". [Feature [#14123]] - Print backtrace and error message in reverse order (oldest call first, most recent call last). When a long backtrace appears on your terminal (TTY), you can easily find the cause line at the bottom of the backtrace. Note that the order is reversed only when backtrace is printed out to the terminal directly. [Feature #8661] [experimental] - Performance improvements - About 5-10% performance improvement by removing all trace instructions from overall bytecode (instruction sequences). The trace instruction was added to support the TracePoint. However, in most cases, TracePoint is not used and trace instructions are pure overhead. Instead, now we use a dynamic instrumentation technique. See [Feature #14104] for more details. - Block passing by a block parameter (e.g. def foo(&b); bar(&b); end) is about 3 times faster than Ruby 2.4 by “Lazy Proc allocation” technique. [Feature #14045] - Mutex is rewritten to be smaller and faster. [Feature #13517] - ERB now generates code from a template which runs twice as fast as Ruby 2.4. - Improve performance of some built-in methods including Array#concat, Enumerable#sort_by, String#concat, String#index, Time#+ and more. - IO.copy_stream uses copy_file_range(2) to copy offload [Feature #13867] - Other notable changes since 2.4 - SecureRandom now prefers OS-provided sources over OpenSSL. [Bug #9569] - Promote cmath, csv, date, dbm, etc, fcntl, fiddle, fileutils, gdbm, ipaddr, scanf, sdbm, stringio, strscan, webrick, zlib from standard libraries to default gems. - Update to Onigmo 6.1.3. - It adds the absence operator. - Note that Ruby 2.4.1 also includes this change. - Update to Psych 3.0.2. - Update to RubyGems 2.7.3. - Update to RDoc 6.0.1. - Switch the lexer from IRB based one to Ripper. This dramatically improves the performance of document generation. - Fix a significant amount of bugs that existed over ten years. - Add support for new Ruby syntax from the latest versions. - Update supported Unicode version to 10.0.0. - Thread.report_on_exception is now set to true by default. This change helps debugging of multi-threaded programs. [Feature #14143] - IO#write now receives multiple arguments [Feature #9323] For details see: https://github.com/ruby/ruby/blob/v2_5_0/NEWS https://github.com/ruby/ruby/compare/v2_4_0...v2_5_0
* Tue Dec 19 2017 mrueckertAATTsuse.de- switch to https urls
* Mon Dec 18 2017 mrueckertAATTsuse.de- update to 2.5.0~rc1 https://www.ruby-lang.org/en/news/2017/12/14/ruby-2-5-0-rc1-released/- added 316f58076d29dcff053256992d9ec19fed7e698f.patch to fix building rbtrace and ruby-prof
* Mon Nov 20 2017 mrueckertAATTsuse.de- disable jemalloc again because of: (boo#1068883) https://github.com/jemalloc/jemalloc/issues/937
* Fri Nov 17 2017 mrueckertAATTsuse.de- update to 60813 see installed /usr/share/doc/packages/ruby2.5/ChangeLog
* Wed Nov 15 2017 mrueckertAATTsuse.de- update to 60739 see installed /usr/share/doc/packages/ruby2.5/ChangeLog
* Wed Nov 15 2017 mrueckertAATTsuse.de- make the whole u-a handling less error prone by having the list in variable ua-binaries
* Thu Nov 09 2017 jdelvareAATTsuse.de- Add conflicts to libruby to make sure ruby and ruby-stdlib are also updated when libruby is updated (bsc#1048072.)
* Thu Nov 09 2017 mrueckertAATTsuse.de- exclude all testsuites for the stdlib gems
* Wed Nov 08 2017 mrueckertAATTsuse.de- build jemalloc
* Tue Oct 31 2017 mrueckertAATTsuse.de- update to 60568 see installed /usr/share/doc/packages/ruby2.5/ChangeLog - this fixes the \"ruby -rubygems\" on 2.5
* Wed Oct 04 2017 mrueckertAATTsuse.de- update intree gem list- bundler is now part of core too!
* Wed Oct 04 2017 mrueckertAATTsuse.de- update to r60035: see installed /usr/share/doc/packages/ruby2.5/ChangeLog- revert some of the wrong Group changes- drop autoreconf -fi and the buildrequires for the related packages
* Fri Sep 22 2017 mrueckertAATTsuse.de- make it easier to sync the versions from the gemspec with the spec file: ruby dump-versions.rb $unpacked_tarball_dir
* Fri Sep 22 2017 mrueckertAATTsuse.de- add conflicts for all intree gems
* Mon Sep 11 2017 jengelhAATTinai.de- Fix RPM groups. Replace old RPM macros by modern ones.- Ensure neutrality of descriptions.
* Fri Sep 08 2017 mrueckertAATTsuse.de- update to 59623
* Wed Aug 09 2017 mrueckertAATTsuse.de- fix gem provides- install macro files with 2.5 version
* Wed Aug 09 2017 mrueckertAATTsuse.de- initial package (Fate#324013)- port 2 patches we still need from the 2.4 package: 0001-make-gem-build-reproducible.patch 0002-gc.c-tick-for-POWER-arch.patch