SEARCH
NEW RPMS
DIRECTORIES
ABOUT
FAQ
VARIOUS
BLOG
DONATE


YUM REPOSITORY

 
 
Changelog for libunistring0-0.9.3-18.1.x86_64.rpm :
Tue Mar 4 13:00:00 2014 pgajdosAATTsuse.com
- fix parallel build

* added parallel-make.patch [bnc#866723] (private)

Wed Dec 18 13:00:00 2013 uweigandAATTde.ibm.com
- libunistring-gnulib-ppc64le.patch: Fix imported gnulib long double
math tests for little-endian PowerPC.

Fri Mar 16 13:00:00 2012 cfarrellAATTsuse.com
- license update: LGPL-3.0+ and GPL-3.0+
Numerous files in tests/ and woedll are GPL-3.0+ licensed. Either put
them in a separate GPL-3.0+ labelled subpackage or use this label for the
main License: line

Sun Mar 11 13:00:00 2012 jengelhAATTmedozas.de
- Nuke unnecessary libunistring binary package: move documentation
files to devel subpackage

Mon Jan 30 13:00:00 2012 jengelhAATTmedozas.de
- Remove redundant tags/sections per specfile guideline suggestions
- Parallel building using %_smp_mflags

Fri Sep 30 14:00:00 2011 crrodriguezAATTopensuse.org
- Workaround qemu-arm bugs.

Mon Aug 30 14:00:00 2010 pgajdosAATTsuse.cz
- updated to version 0.9.3:

* Bug fixes in unistr.h functions:
- The functions u16_to_u32, u16_to_u8, u8_to_u32, u8_to_u16 now fail when
the argument is not valid. Previously, they returned a converted string
where invalid parts were each replaced with U+FFFD.
- The function u8_mbsnlen now counts an incomplete character at the end
of the argument string as 1 character. Previously, it could count as 2
or 3 characters.
- The return value of the u8_stpncpy, u16_stpncpy, u32_stpncpy functions
was incorrect.
- The u8_strcoll, u16_strcoll, u32_strcoll now try harder to give a non-zero
return value.

Mon Mar 15 13:00:00 2010 pgajdosAATTsuse.cz
- updated to version 0.9.2.1:

* The function uc_locale_language now uses the locale of the
current thread, if a thread-specific locale has been set.

Tue Nov 24 13:00:00 2009 pgajdosAATTsuse.cz
- initial version of package 0.9.1.1
- spec file taken from
http://www.pixelbeat.org/patches/libunistring
(PĂĄdraig Brady - needed by guile 1.9.0 and higher