SEARCH
NEW RPMS
DIRECTORIES
ABOUT
FAQ
VARIOUS
BLOG
DONATE


YUM REPOSITORY

 
 

python3-social-auth-core rpm build for : Fedora 31. For other distributions click python3-social-auth-core.

Name : python3-social-auth-core
Version : 3.3.3 Vendor : Fedora Project
Release : 1.fc31 Date : 2020-07-18 05:44:43
Group : Unspecified Source RPM : python-social-auth-core-3.3.3-1.fc31.src.rpm
Size : 0.91 MB
Packager : Fedora Project
Summary : Python Social Auth is an easy to setup social authentication/registration mechanism with support for several frameworks and auth providers.
Description :
Python Social Auth aims to be an easy-to-setup social
authentication and authorization mechanism for Python projects supporting
protocols like OAuth (1 and 2), OpenID and others.

The initial codebase is derived from django-social-auth with the idea of
generalizing the process to suit the different frameworks around, providing
the needed tools to bring support to new frameworks.

django-social-auth itself was a product of modified code from
django-twitter-oauth and django-openid-auth projects.

The project is now split into smaller modules to isolate and reduce
responsibilities and improve reusability.

Documentation: https://python-social-auth.readthedocs.io/en/latest/

If you want social-core to work with azuread (the Azure Active Directory), this
is the package you need.

RPM found in directory: /mirror/download.fedora.redhat.com/pub/fedora/linux/updates/31/Everything/armhfp/Packages/p

Content of RPM  Changelog  Provides Requires

Download
ftp.pbone.net  python3-social-auth-core-3.3.3-1.fc31.noarch.rpm
ftp.pbone.net  python3-social-auth-core-3.3.3-1.fc31.noarch.rpm
ftp.pbone.net  python3-social-auth-core-3.3.3-1.fc31.noarch.rpm
     

Provides :
python-social-auth-core
python3-social-auth-core
python3.7dist(social-auth-core)
python3dist(social-auth-core)

Requires :
python(abi) = 3.7
python3.7dist(cryptography) >= 1.4
python3.7dist(defusedxml) >= 0.5.0rc1
python3.7dist(oauthlib) >= 1.0.3
python3.7dist(pyjwt) >= 1.4
python3.7dist(python3-openid) >= 3.0.10
python3.7dist(requests) >= 2.9.1
python3.7dist(requests-oauthlib) >= 0.6.1
python3.7dist(six) >= 1.10
python3dist(cryptography)
python3dist(defusedxml)
python3dist(oauthlib)
python3dist(python3-openid)
python3dist(requests)
python3dist(requests-oauthlib)
python3dist(six)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsZstd) <= 5.4.18-1


Content of RPM :
/usr/lib/python3.7/site-packages/social_auth_core-3.3.3-py3.7.egg-info
/usr/lib/python3.7/site-packages/social_auth_core-3.3.3-py3.7.egg-info/PKG-INFO
/usr/lib/python3.7/site-packages/social_auth_core-3.3.3-py3.7.egg-info/SOURCES.txt
/usr/lib/python3.7/site-packages/social_auth_core-3.3.3-py3.7.egg-info/dependency_links.txt
/usr/lib/python3.7/site-packages/social_auth_core-3.3.3-py3.7.egg-info/not-zip-safe
/usr/lib/python3.7/site-packages/social_auth_core-3.3.3-py3.7.egg-info/requires.txt
/usr/lib/python3.7/site-packages/social_auth_core-3.3.3-py3.7.egg-info/top_level.txt
/usr/lib/python3.7/site-packages/social_core
/usr/lib/python3.7/site-packages/social_core/__init__.py
/usr/lib/python3.7/site-packages/social_core/__pycache__
/usr/lib/python3.7/site-packages/social_core/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/social_core/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/social_core/__pycache__/actions.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/social_core/__pycache__/actions.cpython-37.pyc
/usr/lib/python3.7/site-packages/social_core/__pycache__/exceptions.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/social_core/__pycache__/exceptions.cpython-37.pyc
/usr/lib/python3.7/site-packages/social_core/__pycache__/storage.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/social_core/__pycache__/storage.cpython-37.pyc
/usr/lib/python3.7/site-packages/social_core/__pycache__/store.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/social_core/__pycache__/store.cpython-37.pyc
/usr/lib/python3.7/site-packages/social_core/__pycache__/strategy.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/social_core/__pycache__/strategy.cpython-37.pyc
/usr/lib/python3.7/site-packages/social_core/__pycache__/utils.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/social_core/__pycache__/utils.cpython-37.pyc
/usr/lib/python3.7/site-packages/social_core/actions.py
/usr/lib/python3.7/site-packages/social_core/backends
/usr/lib/python3.7/site-packages/social_core/backends/__init__.py
/usr/lib/python3.7/site-packages/social_core/backends/__pycache__
/usr/lib/python3.7/site-packages/social_core/backends/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/social_core/backends/__pycache__/__init__.cpython-37.pyc
There is 543 files more in these RPM.