SEARCH
NEW RPMS
DIRECTORIES
ABOUT
FAQ
VARIOUS
BLOG
DONATE


YUM REPOSITORY

 
 

perl-Guard rpm build for : openSUSE Tumbleweed. For other distributions click perl-Guard.

Name : perl-Guard
Version : 1.023 Vendor : openSUSE
Release : 1.16 Date : 2019-07-09 12:15:28
Group : Development/Libraries/Perl Source RPM : perl-Guard-1.023-1.16.src.rpm
Size : 0.03 MB
Packager : https://bugs_opensuse_org
Summary : Safe cleanup blocks
Description :
This module implements so-called \"guards\". A guard is something (usually an
object) that \"guards\" a resource, ensuring that it is cleaned up when
expected.

Specifically, this module supports two different types of guards: guard
objects, which execute a given code block when destroyed, and scoped
guards, which are tied to the scope exit.

RPM found in directory: /mirror/ftp.opensuse.org/history/20190907/tumbleweed/repo/oss/i586

Content of RPM  Changelog  Provides Requires

Download
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
ftp.pbone.net  perl-Guard-1.023-1.16.i586.rpm
     Search for other platforms
perl-Guard-1.023-1.16.sparc.rpm
perl-Guard-1.023-1.16.alpha.rpm
perl-Guard-1.023-1.16.ppc.rpm
perl-Guard-1.023-1.16.ia64.rpm
perl-Guard-1.023-1.16.s390.rpm

Provides :
perl(Guard)
perl-Guard
perl-Guard(x86-32)

Requires :
libc.so.6
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.4)
perl(:MODULE_COMPAT_5.28.1)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1


Content of RPM :
/usr/lib/perl5/vendor_perl/5.28.1/i586-linux-thread-multi/Guard.pm
/usr/lib/perl5/vendor_perl/5.28.1/i586-linux-thread-multi/auto/Guard
/usr/lib/perl5/vendor_perl/5.28.1/i586-linux-thread-multi/auto/Guard/Guard.so
/usr/share/doc/packages/perl-Guard
/usr/share/doc/packages/perl-Guard/COPYING
/usr/share/doc/packages/perl-Guard/Changes
/usr/share/doc/packages/perl-Guard/README
/usr/share/man/man3/Guard.3pm.gz