SEARCH
NEW RPMS
DIRECTORIES
ABOUT
FAQ
VARIOUS
BLOG
DONATE


YUM REPOSITORY

 
 

php-sabre-http rpm build for : Fedora 28. For other distributions click php-sabre-http.

Name : php-sabre-http
Version : 4.2.3 Vendor : Fedora Project
Release : 3.fc28 Date : 2018-02-09 05:37:10
Group : Development/Libraries Source RPM : php-sabre-http-4.2.3-3.fc28.src.rpm
Size : 0.12 MB
Packager : Fedora Project
Summary : Library for dealing with http requests and responses
Description :
This library provides a toolkit to make working with the HTTP protocol easier.

Most PHP scripts run within a HTTP request but accessing information about
the HTTP request is cumbersome at least, mainly do to superglobals and the
CGI standard.

There\'s bad practices, inconsistencies and confusion.
This library is effectively a wrapper around the following PHP constructs:

For Input:
$_GET
$_POST
$_SERVER
php://input or $HTTP_RAW_POST_DATA.

For output:
php://output or echo.
header()

What this library provides, is a Request object, and a Response object.
The objects are extendable and easily mockable.

Autoloader: /usr/share/php/Sabre/HTTP/autoload.php

RPM found in directory: /mirror/archive.fedoraproject.org/fedora-secondary/releases/28/Everything/ppc64/os/Packages/p

Content of RPM  Changelog  Provides Requires

Download
ftp.pbone.net  php-sabre-http-4.2.3-3.fc28.noarch.rpm
ftp.pbone.net  php-sabre-http-4.2.3-3.fc28.noarch.rpm
ftp.pbone.net  php-sabre-http-4.2.3-3.fc28.noarch.rpm
ftp.pbone.net  php-sabre-http-4.2.3-3.fc28.noarch.rpm
ftp.pbone.net  php-sabre-http-4.2.3-3.fc28.noarch.rpm
ftp.pbone.net  php-sabre-http-4.2.3-3.fc28.noarch.rpm
ftp.pbone.net  php-sabre-http-4.2.3-3.fc28.noarch.rpm
     

Provides :
php-composer(sabre/http)
php-sabre-http

Requires :
php(language) > 5.4
php-composer(fedora/autoloader)
php-composer(sabre/event) >= 1.0.0
php-composer(sabre/event) >= 2.0.2
php-composer(sabre/event) < 4
php-composer(sabre/uri) >= 1.0
php-composer(sabre/uri) < 2
php-ctype
php-curl
php-date
php-hash
php-mbstring
php-pcre
php-spl
php-xml
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1


Content of RPM :
/usr/share/doc/php-sabre-http
/usr/share/doc/php-sabre-http/CHANGELOG.md
/usr/share/doc/php-sabre-http/README.md
/usr/share/doc/php-sabre-http/composer.json
/usr/share/licenses/php-sabre-http
/usr/share/licenses/php-sabre-http/LICENSE
/usr/share/php/Sabre/HTTP
/usr/share/php/Sabre/HTTP/Auth
/usr/share/php/Sabre/HTTP/Auth/AWS.php
/usr/share/php/Sabre/HTTP/Auth/AbstractAuth.php
/usr/share/php/Sabre/HTTP/Auth/Basic.php
/usr/share/php/Sabre/HTTP/Auth/Bearer.php
/usr/share/php/Sabre/HTTP/Auth/Digest.php
/usr/share/php/Sabre/HTTP/Client.php
/usr/share/php/Sabre/HTTP/ClientException.php
/usr/share/php/Sabre/HTTP/ClientHttpException.php
/usr/share/php/Sabre/HTTP/HttpException.php
/usr/share/php/Sabre/HTTP/Message.php
/usr/share/php/Sabre/HTTP/MessageDecoratorTrait.php
/usr/share/php/Sabre/HTTP/MessageInterface.php
/usr/share/php/Sabre/HTTP/Request.php
/usr/share/php/Sabre/HTTP/RequestDecorator.php
/usr/share/php/Sabre/HTTP/RequestInterface.php
/usr/share/php/Sabre/HTTP/Response.php
/usr/share/php/Sabre/HTTP/ResponseDecorator.php
/usr/share/php/Sabre/HTTP/ResponseInterface.php
/usr/share/php/Sabre/HTTP/Sapi.php
/usr/share/php/Sabre/HTTP/URLUtil.php
/usr/share/php/Sabre/HTTP/Util.php
/usr/share/php/Sabre/HTTP/Version.php
There is 2 files more in these RPM.