SEARCH
NEW RPMS
DIRECTORIES
ABOUT
FAQ
VARIOUS
BLOG
DONATE


YUM REPOSITORY

 
 

ansible-bender rpm build for : Fedora 30. For other distributions click ansible-bender.

Name : ansible-bender
Version : 0.7.0 Vendor : Fedora Project
Release : 1.fc30 Date : 2019-07-04 01:37:27
Group : Unspecified Source RPM : ansible-bender-0.7.0-1.fc30.src.rpm
Size : 0.21 MB
Packager : Fedora Project
Summary : Build container images using Ansible playbooks
Description :
This is a tool which bends containers using Ansible playbooks and
turns them into container images. It has a pluggable builder selection
- it is up to you to pick the tool which will be used to construct
your container image. Right now the only supported builder is
buildah. More to come in the future. Ansible-bender (ab) relies on
Ansible connection plugins for performing builds.

tl;dr Ansible is the frontend, buildah is the backend.

RPM found in directory: /mirror/download.fedora.redhat.com/pub/fedora/linux/updates/30/Everything/armhfp/Packages/a

Content of RPM  Changelog  Provides Requires

Download
ftp.ntua.gr  ansible-bender-0.7.0-1.fc30.noarch.rpm
ftp.ntua.gr  ansible-bender-0.7.0-1.fc30.noarch.rpm
ftp.ntua.gr  ansible-bender-0.7.0-1.fc30.noarch.rpm
ftp.pbone.net  ansible-bender-0.7.0-1.fc30.noarch.rpm
ftp.pbone.net  ansible-bender-0.7.0-1.fc30.noarch.rpm
ftp.pbone.net  ansible-bender-0.7.0-1.fc30.noarch.rpm
     

Provides :
ansible-bender
python3.7dist(ansible-bender)
python3dist(ansible-bender)

Requires :
/usr/bin/python3
ansible
buildah
python(abi) = 3.7
python3.7dist(jsonschema)
python3.7dist(pyyaml)
python3.7dist(setuptools)
python3.7dist(tabulate)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1


Content of RPM :
/usr/bin/ansible-bender
/usr/lib/python3.7/site-packages/ansible_bender
/usr/lib/python3.7/site-packages/ansible_bender-0.7.0-py3.7.egg-info
/usr/lib/python3.7/site-packages/ansible_bender-0.7.0-py3.7.egg-info/PKG-INFO
/usr/lib/python3.7/site-packages/ansible_bender-0.7.0-py3.7.egg-info/SOURCES.txt
/usr/lib/python3.7/site-packages/ansible_bender-0.7.0-py3.7.egg-info/dependency_links.txt
/usr/lib/python3.7/site-packages/ansible_bender-0.7.0-py3.7.egg-info/entry_points.txt
/usr/lib/python3.7/site-packages/ansible_bender-0.7.0-py3.7.egg-info/requires.txt
/usr/lib/python3.7/site-packages/ansible_bender-0.7.0-py3.7.egg-info/top_level.txt
/usr/lib/python3.7/site-packages/ansible_bender/__init__.py
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/api.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/api.cpython-37.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/builder.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/builder.cpython-37.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/cli.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/cli.cpython-37.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/conf.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/conf.cpython-37.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/constants.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/constants.cpython-37.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/core.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/core.cpython-37.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/db.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/db.cpython-37.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/exceptions.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/exceptions.cpython-37.pyc
/usr/lib/python3.7/site-packages/ansible_bender/__pycache__/okd.cpython-37.opt-1.pyc
There is 43 files more in these RPM.