SEARCH
NEW RPMS
DIRECTORIES
ABOUT
FAQ
VARIOUS
BLOG
DONATE


YUM REPOSITORY

 
 

rubygem-paranoia rpm build for : Fedora Other. For other distributions click rubygem-paranoia.

Name : rubygem-paranoia
Version : 2.3.1 Vendor : Fedora Project
Release : 3.fc28 Date : 2018-02-09 17:08:31
Group : Unspecified Source RPM : rubygem-paranoia-2.3.1-3.fc28.src.rpm
Size : 0.01 MB
Packager : Fedora Project
Summary : Cleaner re-implementation of acts_as_paranoid (ActiveRecord soft-delete plugin)
Description :
Paranoia is a re-implementation of acts_as_paranoid for Rails 3, 4, and 5,
using much, much, much less code. You would use either plugin / gem if you
wished that when you called destroy on an Active Record object that it
didn\'t actually destroy it, but just \"hid\" the record. Paranoia does this
by setting a deleted_at field to the current time when you destroy a record,
and hides it by scoping all queries on your model to only include records
which do not have a deleted_at field.

RPM found in directory: /mirror/download.fedora.redhat.com/pub/fedora/linux/development/30/Everything/aarch64/os/Packages/r

Content of RPM  Changelog  Provides Requires

Download
ftp.pbone.net  rubygem-paranoia-2.3.1-3.fc28.noarch.rpm
ftp.pbone.net  rubygem-paranoia-2.3.1-3.fc28.noarch.rpm
ftp.pbone.net  rubygem-paranoia-2.3.1-3.fc28.noarch.rpm
ftp.pbone.net  rubygem-paranoia-2.3.1-3.fc28.noarch.rpm
ftp.pbone.net  rubygem-paranoia-2.3.1-3.fc28.noarch.rpm
ftp.pbone.net  rubygem-paranoia-2.3.1-3.fc28.noarch.rpm
     

Provides :
rubygem(paranoia)
rubygem-paranoia

Requires :
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
ruby(rubygems) >= 1.3.6
rubygem(activerecord) >= 4.0
rubygem(activerecord) < 5.2


Content of RPM :
/usr/share/gems/gems/paranoia-2.3.1
/usr/share/gems/gems/paranoia-2.3.1/LICENSE
/usr/share/gems/gems/paranoia-2.3.1/lib
/usr/share/gems/gems/paranoia-2.3.1/lib/paranoia
/usr/share/gems/gems/paranoia-2.3.1/lib/paranoia.rb
/usr/share/gems/gems/paranoia-2.3.1/lib/paranoia/rspec.rb
/usr/share/gems/gems/paranoia-2.3.1/lib/paranoia/version.rb
/usr/share/gems/specifications/paranoia-2.3.1.gemspec