SEARCH
NEW RPMS
DIRECTORIES
ABOUT
FAQ
VARIOUS
BLOG
DONATE


YUM REPOSITORY

 
 

ruby2.1 rpm build for : openSUSE Leap 42. For other distributions click ruby2.1.

Name : ruby2.1
Version : 2.1.5 Vendor : obs://build_opensuse_org/home:loosi
Release : 1.1 Date : 2016-04-18 15:38:09
Group : Development/Languages/Ruby Source RPM : ruby2.1-2.1.5-1.1.src.rpm
Size : 14.05 MB
Packager : (none)
Summary : An Interpreted Object-Oriented Scripting Language
Description :
Ruby is the interpreted scripting language for quick and
easy object-oriented programming. It has many features to
process text files and to do system management tasks (as in
Perl). It is simple, straight-forward, and extensible.


== Features of Ruby

* Simple Syntax
* *Normal* Object-Oriented features(ex. class, method calls)
* *Advanced* Object-Oriented features(ex. Mix-in, Singleton-method)
* Operator Overloading
* Exception Handling
* Iterators and Closures
* Garbage Collection
* Dynamic Loading of Object files(on some architecture)
* Highly Portable (works on many Unix-like/POSIX compatible platforms
as well as Windows, Mac OS X, BeOS etc.)
cf. http://bugs.ruby-lang.org/projects/ruby-trunk/wiki/SupportedPlatforms

RPM found in directory: /mirror/ftp5.gwdg.de/pub/opensuse/repositories/home:/loosi/openSUSE_Leap_42.1/x86_64

Content of RPM  Changelog  Provides Requires

Download
ftp.pbone.net  ruby2.1-2.1.5-1.1.x86_64.rpm
ftp.pbone.net  ruby2.1-2.1.5-1.1.x86_64.rpm
     

Provides :
big5.so()(64bit)
bigdecimal.so()(64bit)
bubblebabble.so()(64bit)
callback.so()(64bit)
chinese.so()(64bit)
complex.so()(64bit)
console.so()(64bit)
continuation.so()(64bit)
coverage.so()(64bit)
cp949.so()(64bit)
cparse.so()(64bit)
date_core.so()(64bit)
dbm.so()(64bit)
digest.so()(64bit)
dl.so()(64bit)
emacs_mule.so()(64bit)
emoji.so()(64bit)
emoji_iso2022_kddi.so()(64bit)
emoji_sjis_docomo.so()(64bit)
emoji_sjis_kddi.so()(64bit)
emoji_sjis_softbank.so()(64bit)
encdb.so()(64bit)
escape.so()(64bit)
etc.so()(64bit)
euc_jp.so()(64bit)
euc_kr.so()(64bit)
euc_tw.so()(64bit)
fcntl.so()(64bit)
fiber.so()(64bit)
fiddle.so()(64bit)
gb18030.so()(64bit)
gb2312.so()(64bit)
gbk.so()(64bit)
gdbm.so()(64bit)
generator.so()(64bit)
iso2022.so()(64bit)
iso_8859_1.so()(64bit)
iso_8859_10.so()(64bit)
iso_8859_11.so()(64bit)
iso_8859_13.so()(64bit)
iso_8859_14.so()(64bit)
iso_8859_15.so()(64bit)
iso_8859_16.so()(64bit)
iso_8859_2.so()(64bit)
iso_8859_3.so()(64bit)
iso_8859_4.so()(64bit)
iso_8859_5.so()(64bit)
iso_8859_6.so()(64bit)
iso_8859_7.so()(64bit)
iso_8859_8.so()(64bit)
iso_8859_9.so()(64bit)
japanese.so()(64bit)
japanese_euc.so()(64bit)
japanese_sjis.so()(64bit)
koi8_r.so()(64bit)
koi8_u.so()(64bit)
korean.so()(64bit)
libruby2.1.so.2.1()(64bit)
md5.so()(64bit)
nkf.so()(64bit)
nonblock.so()(64bit)
objspace.so()(64bit)
openssl.so()(64bit)
parser.so()(64bit)
pathname.so()(64bit)
psych.so()(64bit)
pty.so()(64bit)
rational.so()(64bit)
readline.so()(64bit)
ripper.so()(64bit)
rmd160.so()(64bit)
ruby(abi)
ruby(release)
ruby2.1
ruby2.1(x86-64)
rubygem(2.1.0:bigdecimal)
rubygem(2.1.0:io-console)
rubygem(2.1.0:json)
rubygem(2.1.0:minitest)
rubygem(2.1.0:psych)
rubygem(2.1.0:rake)
rubygem(2.1.0:rdoc)
rubygem(2.1.0:test-unit)
rubygem(bigdecimal)
rubygem(io-console)
rubygem(json)
rubygem(minitest)
rubygem(psych)
rubygem(rake)
rubygem(rdoc)
rubygem(test-unit)
rubygem-bigdecimal
rubygem-io-console
rubygem-json
rubygem-minitest
rubygem-psych
rubygem-rake
rubygem-rdoc
rubygem-test-unit
rubygems
sdbm.so()(64bit)
sha1.so()(64bit)
sha2.so()(64bit)
shift_jis.so()(64bit)
single_byte.so()(64bit)
sizeof.so()(64bit)
socket.so()(64bit)
stringio.so()(64bit)
strscan.so()(64bit)
syslog.so()(64bit)
thread.so()(64bit)
transdb.so()(64bit)
utf8_mac.so()(64bit)
utf_16_32.so()(64bit)
utf_16be.so()(64bit)
utf_16le.so()(64bit)
utf_32be.so()(64bit)
utf_32le.so()(64bit)
wait.so()(64bit)
windows_1251.so()(64bit)
windows_31j.so()(64bit)
zlib.so()(64bit)

Requires :
libc.so.6()(64bit)
libc.so.6(GLIBC_2.6)(64bit)
libgdbm_compat.so.4()(64bit)
libcrypt.so.1()(64bit)
/usr/bin/env
libm.so.6(GLIBC_2.2.5)(64bit)
libz.so.1(ZLIB_1.2.2)(64bit)
libpthread.so.0(GLIBC_2.3.2)(64bit)
libffi.so.4()(64bit)
libreadline.so.6()(64bit)
ld-linux-x86-64.so.2(GLIBC_2.2.5)(64bit)
libdl.so.2()(64bit)
libgmp.so.10()(64bit)
libc.so.6(GLIBC_2.14)(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
libpthread.so.0(GLIBC_2.2.5)(64bit)
libcrypto.so.1.0.0()(64bit)
libpthread.so.0()(64bit)
/usr/bin/ruby2.1
libc.so.6(GLIBC_2.10)(64bit)
libcrypt.so.1(GLIBC_2.2.5)(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
ld-linux-x86-64.so.2()(64bit)
libgdbm.so.4()(64bit)
libc.so.6(GLIBC_2.4)(64bit)
rpmlib(PayloadIsLzma) <= 4.4.6-1
libm.so.6()(64bit)
libc.so.6(GLIBC_2.3)(64bit)
libdl.so.2(GLIBC_2.2.5)(64bit)
libpthread.so.0(GLIBC_2.3.3)(64bit)
/sbin/ldconfig
libssl.so.1.0.0()(64bit)
libz.so.1()(64bit)
libc.so.6(GLIBC_2.9)(64bit)
libc.so.6(GLIBC_2.17)(64bit)
libruby2.1.so.2.1()(64bit)


Content of RPM :
/usr/bin/erb2.1
/usr/bin/gem2.1
/usr/bin/irb2.1
/usr/bin/rake2.1
/usr/bin/rdoc2.1
/usr/bin/ri2.1
/usr/bin/ruby2.1
/usr/bin/testrb2.1
/usr/lib64/libruby2.1.so.2.1
/usr/lib64/libruby2.1.so.2.1.0
/usr/lib64/ruby
/usr/lib64/ruby/2.1.0
/usr/lib64/ruby/2.1.0/English.rb
/usr/lib64/ruby/2.1.0/abbrev.rb
/usr/lib64/ruby/2.1.0/base64.rb
/usr/lib64/ruby/2.1.0/benchmark.rb
/usr/lib64/ruby/2.1.0/bigdecimal
/usr/lib64/ruby/2.1.0/bigdecimal/jacobian.rb
/usr/lib64/ruby/2.1.0/bigdecimal/ludcmp.rb
/usr/lib64/ruby/2.1.0/bigdecimal/math.rb
/usr/lib64/ruby/2.1.0/bigdecimal/newton.rb
/usr/lib64/ruby/2.1.0/bigdecimal/util.rb
/usr/lib64/ruby/2.1.0/cgi
/usr/lib64/ruby/2.1.0/cgi.rb
/usr/lib64/ruby/2.1.0/cgi/cookie.rb
/usr/lib64/ruby/2.1.0/cgi/core.rb
/usr/lib64/ruby/2.1.0/cgi/html.rb
/usr/lib64/ruby/2.1.0/cgi/session
/usr/lib64/ruby/2.1.0/cgi/session.rb
/usr/lib64/ruby/2.1.0/cgi/session/pstore.rb
There is 1004 files more in these RPM.