SEARCH
NEW RPMS
DIRECTORIES
ABOUT
FAQ
VARIOUS
BLOG
DONATE




YUM REPOSITORY

 
 

perl-MooseX-LazyRequire rpm build for : Mandriva 2011. For other distributions click perl-MooseX-LazyRequire.

Name : perl-MooseX-LazyRequire
Version : 0.70.0 Vendor : Mandriva
Release : 1 Date : 2011-04-17 16:09:51
Group : Development/Perl Source RPM : perl-MooseX-LazyRequire-0.70.0-1.src.rpm
Size : 0.03 MB
Packager : Guillaume Rousse < guillomovitch_mandriva_org>
Summary : Required attributes which fail only when trying to use them
Description :
This module adds a \'lazy_require\' option to Moose attribute declarations.

The reader methods for all attributes with that option will throw an
exception unless a value for the attributes was provided earlier by a
constructor parameter or through a writer method.

RPM found in directory: /mirror/carroll.cac.psu.edu/pub/linux/distributions/mandrakelinux/official/2011/i586/media/contrib/release

Content of RPM  Changelog  Provides Requires

Download
ftp.gwdg.de  perl-MooseX-LazyRequire-0.70.0-1-mdv2011.0.noarch.rpm
ftp.gwdg.de  perl-MooseX-LazyRequire-0.70.0-1-mdv2011.0.noarch.rpm
ftp.gwdg.de  perl-MooseX-LazyRequire-0.70.0-1-mdv2011.0.noarch.rpm
ftp.gwdg.de  perl-MooseX-LazyRequire-0.70.0-1-mdv2011.0.noarch.rpm
bo.mirror.garr.it  perl-MooseX-LazyRequire-0.70.0-1-mdv2011.0.noarch.rpm
bo.mirror.garr.it  perl-MooseX-LazyRequire-0.70.0-1-mdv2011.0.noarch.rpm
ftp.icm.edu.pl  perl-MooseX-LazyRequire-0.70.0-1-mdv2011.0.noarch.rpm
ftp.icm.edu.pl  perl-MooseX-LazyRequire-0.70.0-1-mdv2011.0.noarch.rpm
ftp.icm.edu.pl  perl-MooseX-LazyRequire-0.70.0-1-mdv2011.0.noarch.rpm
ftp.icm.edu.pl  perl-MooseX-LazyRequire-0.70.0-1-mdv2011.0.noarch.rpm
ftp.pbone.net  perl-MooseX-LazyRequire-0.70.0-1-mdv2011.0.noarch.rpm
     

Provides :
perl(MooseX::LazyRequire)
perl(MooseX::LazyRequire::Meta::Attribute::Trait::LazyRequire)
perl-MooseX-LazyRequire

Requires :
perl-base >= 2:5.12.3
perl(Carp)
perl(Moose) >= 0.940.0
perl(Moose::Exporter)
perl(Moose::Role)
perl(MooseX::Types::Moose)
perl(aliased) >= 0.300.0
perl(namespace::autoclean)
rpmlib(PayloadIsLzma) <= 4.4.6-1


Content of RPM :
/usr/lib/perl5/vendor_perl/5.12.3/MooseX
/usr/lib/perl5/vendor_perl/5.12.3/MooseX/LazyRequire
/usr/lib/perl5/vendor_perl/5.12.3/MooseX/LazyRequire.pm
/usr/lib/perl5/vendor_perl/5.12.3/MooseX/LazyRequire/Meta
/usr/lib/perl5/vendor_perl/5.12.3/MooseX/LazyRequire/Meta/Attribute
/usr/lib/perl5/vendor_perl/5.12.3/MooseX/LazyRequire/Meta/Attribute/Trait
/usr/lib/perl5/vendor_perl/5.12.3/MooseX/LazyRequire/Meta/Attribute/Trait/LazyRequire.pm
/usr/share/doc/perl-MooseX-LazyRequire
/usr/share/doc/perl-MooseX-LazyRequire/Changes
/usr/share/doc/perl-MooseX-LazyRequire/LICENSE
/usr/share/doc/perl-MooseX-LazyRequire/META.yml
/usr/share/doc/perl-MooseX-LazyRequire/README
/usr/share/man/man3/MooseX::LazyRequire.3pm.xz
/usr/share/man/man3/MooseX::LazyRequire::Meta::Attribute::Trait::LazyRequire.3pm.xz