SEARCH
NEW RPMS
DIRECTORIES
ABOUT
FAQ
VARIOUS
BLOG
DONATE




YUM REPOSITORY

 
 

perl-Perl-MinimumVersion rpm build for : Mandriva 2010. For other distributions click perl-Perl-MinimumVersion.

Name : perl-Perl-MinimumVersion
Version : 1.240.0 Vendor : Mandriva
Release : 1mdv2010.1 Date : 2010-01-22 15:37:29
Group : Development/Perl Source RPM : perl-Perl-MinimumVersion-1.240.0-1mdv2010.1.src.rpm
Size : 0.07 MB
Packager : Jérôme Quelin < jquelin_mandriva_org>
Summary : Find a minimum required version of perl for Perl code
Description :
\'Perl::MinimumVersion\' takes Perl source code and calculates the minimum
version of perl required to be able to run it. Because it is based on the
PPI manpage, it can do this without having to actually load the code.

Currently it tests both the syntax of your code, and the use of explicit
version dependencies such as \'require 5.005\'.

Future plans are to also add support for tracing module dependencies.

RPM found in directory: /mirror/carroll.cac.psu.edu/pub/linux/distributions/mandrakelinux/official/2010.1/i586/media/contrib/release

Content of RPM  Changelog  Provides Requires

Download
ftp.gwdg.de  perl-Perl-MinimumVersion-1.240.0-1mdv2010.1.noarch.rpm
ftp.gwdg.de  perl-Perl-MinimumVersion-1.240.0-1mdv2010.1.noarch.rpm
ftp.gwdg.de  perl-Perl-MinimumVersion-1.240.0-1mdv2010.1.noarch.rpm
ftp.gwdg.de  perl-Perl-MinimumVersion-1.240.0-1mdv2010.1.noarch.rpm
bo.mirror.garr.it  perl-Perl-MinimumVersion-1.240.0-1mdv2010.1.noarch.rpm
bo.mirror.garr.it  perl-Perl-MinimumVersion-1.240.0-1mdv2010.1.noarch.rpm
ftp.icm.edu.pl  perl-Perl-MinimumVersion-1.240.0-1mdv2010.1.noarch.rpm
ftp.icm.edu.pl  perl-Perl-MinimumVersion-1.240.0-1mdv2010.1.noarch.rpm
ftp.icm.edu.pl  perl-Perl-MinimumVersion-1.240.0-1mdv2010.1.noarch.rpm
ftp.icm.edu.pl  perl-Perl-MinimumVersion-1.240.0-1mdv2010.1.noarch.rpm
ftp.pbone.net  perl-Perl-MinimumVersion-1.240.0-1mdv2010.1.noarch.rpm
ftp.isu.edu.tw  perl-Perl-MinimumVersion-1.240.0-1mdv2010.1.noarch.rpm
ftp.isu.edu.tw  perl-Perl-MinimumVersion-1.240.0-1mdv2010.1.noarch.rpm
     

Provides :
perl(Perl::MinimumVersion)
perl(Perl::MinimumVersion::Reason)
perl-Perl-MinimumVersion

Requires :
perl(Getopt::Long)
perl(File::Find::Rule)
perl(File::Spec)
perl(PPI)
perl(Exporter)
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
perl(Perl::Critic::Utils) => 1.104.0
rpmlib(CompressedFileNames) <= 3.0.4-1
perl(List::Util)
rpmlib(VersionedDependencies) <= 3.0.3-1
perl(Perl::MinimumVersion::Reason)
perl(PPI::Util)
rpmlib(PayloadIsLzma) <= 4.4.6-1
perl(Carp)
perl-base => 2:5.10.1
perl(File::Find::Rule::Perl)
perl(Perl::MinimumVersion)
perl(Params::Util)


Content of RPM :
/usr/bin/perlver
/usr/lib/perl5/vendor_perl/5.10.1/Perl
/usr/lib/perl5/vendor_perl/5.10.1/Perl/MinimumVersion
/usr/lib/perl5/vendor_perl/5.10.1/Perl/MinimumVersion.pm
/usr/lib/perl5/vendor_perl/5.10.1/Perl/MinimumVersion/Reason.pm
/usr/lib/perl5/vendor_perl/5.10.1/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.10.1/i386-linux-thread-multi/auto
/usr/lib/perl5/vendor_perl/5.10.1/i386-linux-thread-multi/auto/Perl
/usr/lib/perl5/vendor_perl/5.10.1/i386-linux-thread-multi/auto/Perl/MinimumVersion
/usr/share/doc/perl-Perl-MinimumVersion
/usr/share/doc/perl-Perl-MinimumVersion/Changes
/usr/share/doc/perl-Perl-MinimumVersion/LICENSE
/usr/share/doc/perl-Perl-MinimumVersion/README
/usr/share/man/man1/perlver.1.lzma
/usr/share/man/man3/Perl::MinimumVersion.3pm.lzma