SEARCH
NEW RPMS
DIRECTORIES
ABOUT
FAQ
VARIOUS
BLOG
DONATE


YUM REPOSITORY

 
 
File firefox-ta-68.4.0-1.mga7.noarch.rpm is obsolete. Try find newer firefox-ta for Mageia 7